re-deploying services at the moment.
Incident Report for DataCite
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 15, 2017 - 11:45 UTC
Identified
Services are being re-deployed, this might lead to a few minutes of down time
Posted 9 months ago. Nov 15, 2017 - 11:00 UTC