MDS
Incident Report for DataCite
Resolved
Issues with the DB have been solved. MDS is back to normal. We are sorry for the inconvenience!
Posted Apr 25, 2016 - 12:59 UTC
Investigating
MDS is not responding properly to requests, returns 502 status.
Posted Apr 24, 2016 - 12:44 UTC