Search slow in morning hours
Incident Report for DataCite
Resolved
Search server recovered
Posted Aug 14, 2016 - 09:25 UTC
Investigating
We are experiencing problems with slow search in the morning hours.
Posted Aug 14, 2016 - 08:30 UTC