Search service is having performance issues
Incident Report for DataCite
Resolved
All services are back to normal.
Posted 10 months ago. Oct 29, 2017 - 16:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Oct 26, 2017 - 07:31 UTC