Updated SSL Certificate
Incident Report for DataCite
Resolved
SSL certificates have been successfully updated.
Posted Jul 12, 2016 - 11:39 UTC
Monitoring
DataCite has updated its SSL certificate for several servers. The process will be completed on Sunday. We don't expect any issues for users.
Posted Jul 05, 2016 - 18:17 UTC