We are experiencing intermittend availability issues with several of our services
Incident Report for DataCite
Resolved
We have resolved the issue, one of our proxy servers was not working properly.
Posted 11 months ago. Jan 06, 2017 - 07:45 UTC
Investigating
We are investigating the issue.
Posted 11 months ago. Jan 05, 2017 - 06:58 UTC