We are experiencing a heavy load on our MDS database
Incident Report for DataCite
Resolved
The issue with heavy database load has been resolved.
Posted 8 months ago. Jan 26, 2017 - 22:10 UTC
Identified
This issue affects several services, including API and Search. We have identified the issue and are working on a fix.
Posted 8 months ago. Jan 26, 2017 - 16:02 UTC