Profiles
Incident Report for DataCite
Resolved
The issue has been resolved and ORCID profiles are updated properly again.
Posted May 14, 2016 - 11:42 UTC
Investigating
There is an issue with sending claims to the ORCID registry. We are investigating.
Posted May 14, 2016 - 04:31 UTC