Mitigation strategies have been deployed to help with some anonymous traffic that was causing increased load on our search cluster. Services appear to be resuming normal function but with potentially still some degraded performance, we will continue monitoring.
Posted Dec 17, 2024 - 09:56 UTC
Investigating
We're currently experiencing increased load on our services and are investigating the underlying cause and mitigation that we can take.
This mostly appears to be affecting our search cluster, and therefore has a knock-on effect to queries and retrieval through DataCite Commons and some functionality in Fabrica.
DOI Registration services should be unaffected, although may experience timeouts viewing content after registration.
Posted Dec 16, 2024 - 19:28 UTC
This incident affected: API Servers (REST API, OAI-PMH, GraphQL API) and Frontend Applications (Fabrica, Commons).